[roll third_party/pigweed] pw_env_setup: Stop pulling down Rust

Rust was only used by PyOxidizer which we're no longer supporting.

Original-Reviewed-on: https://pigweed-review.googlesource.com/c/pigweed/pigweed/+/42901

third_party/pigweed Rolled-Commits: cc9c0555775eabe..69bc4e018f67964
Roller-URL: https://ci.chromium.org/b/8848415012396487792
Cq-Cl-Tag: roller-builder:pigweed-sample-project-roller
Cq-Cl-Tag: roller-bid:8848415012396487792
CQ-Do-Not-Cancel-Tryjobs: true
Change-Id: I59df93fc10be20f2c872c452537e99256e716546
Reviewed-on: https://pigweed-review.googlesource.com/c/pigweed/sample_project/+/43322
Reviewed-by: Pigweed Integration Roller <pigweed-integration-roller@pigweed.google.com.iam.gserviceaccount.com>
Commit-Queue: Pigweed Integration Roller <pigweed-integration-roller@pigweed.google.com.iam.gserviceaccount.com>
diff --git a/third_party/pigweed b/third_party/pigweed
index cc9c055..69bc4e0 160000
--- a/third_party/pigweed
+++ b/third_party/pigweed
@@ -1 +1 @@
-Subproject commit cc9c0555775eabe8e31ddbfe626977d4c9a9722d
+Subproject commit 69bc4e018f67964224ed9b82c37b4f2b241e167b